Bug Tracker

Opened 6 years ago

Closed 6 years ago

#13295 closed bug (duplicate)

KeyError: 'captcha_redirect'

Reported by: anonymous Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: git
Keywords: Cc:
Blocked by: Blocking:

Description

How to Reproduce

While doing a POST operation on /, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'2e3c259cd0b5eaaad20206e9',
 'recaptcha_challenge_field': u'03AHJ_VuuveTDS5LQgfUTw6zSC8_z_a55oE4H5cVtPSbIJXK8oWcEBkkmg3iPEobHvgwbCWhPXqYdq7ymyqJ2_DIqtA0fGabYXcwi4DSyJAwhUIFZwhk1uj69Oc7R-qohUnX44jus5codzslQr1A6iCl8Ew1NyATBhm01-dbDX8dzL3u-N43sOJXU',
 'recaptcha_response_field': u'ceenhly reign'}

User agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_2) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.52 Safari/537.17

System Information

System information not available

Enabled Plugins

Plugin information not available

Python Traceback

Traceback (most recent call last):
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 511, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 202, in dispatch
    chosen_handler)
  File "/usr/local/lib/python2.6/dist-packages/Trac-0.12.1-py2.6.egg/trac/web/main.py", line 344, in _pre_process_request
    chosen_handler = filter_.pre_process_request(req, chosen_handler)
  File "/usr/local/lib/python2.6/dist-packages/TracSpamFilter-0.4.1dev_r10170-py2.6.egg/tracspamfilter/captcha/api.py", line 119, in pre_process_request
    del req.session['captcha_redirect']
KeyError: 'captcha_redirect'

Change History (1)

comment:1 Changed 6 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #13302.

Note: See TracTickets for help on using tickets.