Bug Tracker

Opened 11 years ago

Closed 11 years ago

#1329 closed bug (worksforme)

Appending TableData cell to a TableRow only inserts the content of the cell

Reported by: Justise Owned by: brandon
Priority: major Milestone: 1.1.4
Component: core Version: 1.1.3
Keywords: table manipulation Cc:
Blocked by: Blocking:

Description

When I select a row and append to each row as follows, only the contents of the cell get appended.

$(document).ready( function() {

$("TR").append("<TD>4</TD>");

});

Results in the HTML <tr>

<td>1</td> <td>2</td> <td>3</td>

4</tr>

Obviously I was expecting <tr>

<td>1</td> <td>2</td> <td>3</td> <td>4</td>

</tr>

Attachments (1)

jQueryTest.html (707 bytes) - added by Justise 11 years ago.

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by Justise

Attachment: jQueryTest.html added

comment:1 Changed 11 years ago by john

Milestone: 1.1.31.1.4
need: ReviewTest Case
Owner: set to brandon
Version: 1.1.21.1.3

comment:2 Changed 11 years ago by brandon

Resolution: worksforme
Status: newclosed

This works for me in Firefox, Safari and IE. Feel free to reopen with some more specifics in how to reproduce the issue.

Note: See TracTickets for help on using tickets.