Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#13280 closed bug (duplicate)

create a jq element from string

Reported by: [email protected] Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.0
Keywords: Cc:
Blocked by: Blocking:

Description

var s = '\
	<form></form>';
$(s);

when i use v1.9.0 this way, firefox shows error:

"Error: Syntax error, unrecognized expression: <form></form>

slice.call( docElem.childNodes, 0 )[0].nodeType;"

notice, there is a "\t" before "<form>"

Change History (3)

comment:1 Changed 10 years ago by Motty

This is a duplicate of #13223, also see the upgrade guide... but I think it's completely ridiculous that jQuery won't trim the string before determining if it is "valid" html or not.

Anyway, I'm now getting this error when initializing jQuery 1.9.0 in Firefox 18.0.1 on a page with an EMPTY body!

<!DOCTYPE html>
<html>
<head>
<script src="http://ajax.googleapis.com/ajax/libs/jquery/1.9.0/jquery.js"></script>
</head>
<body>
</body>
</html>
Last edited 10 years ago by Motty (previous) (diff)

comment:2 Changed 10 years ago by timmywil

Resolution: duplicate
Status: newclosed

Duplicate of #13233.

comment:3 Changed 10 years ago by [email protected]

I'm afraid that this bug has not be fixed in 1.9.1.

I have seen the blog "http://blog.jquery.com/2013/02/04/jquery-1-9-1-released/", Ticket #13233 resolved, but this one left.

The console always show me an error: Error: Syntax error, unrecognized expression: <form></form> throw new Error( "Syntax error, unrecognized expression: " + msg );

Note: See TracTickets for help on using tickets.