Bug Tracker

Opened 5 years ago

Closed 5 years ago

#13256 closed bug (duplicate)

problem with .after()

Reported by: anonymous Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 2.0b1
Keywords: Cc:
Blocked by: Blocking:

Description

strange behaviour of .after() in 2.0b1

the following works fine with jQ1.9 but not in 2.0b1:

$('#comments').after(responseText);

the setup:

<tr id='comments'>

<td>&nbsp;</td>

</tr> <tr>

<td>end of comments</td>

</tr>

in jQ 1.9 it is inserted correctly:

<tr id='comments'>

<td>&nbsp;</td>

</tr> <tr> ........ </tr> <tr>

<td>end of comments</td>

</tr>

in jQ 2.0b1 it looks like that

<tr id='comments'>

<td>&nbsp;</td>

</tr> <tbody> <tr> ........ </tr> </tbody> <tr>

<td>end of comments</td>

</tr>

have no idea where the tbody is generated. it breaks my layout. in 1.9 it's not there...

Change History (1)

comment:1 Changed 5 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #13232.
Check out the duplicate ticket, this should be fixed soon.

Note: See TracTickets for help on using tickets.