Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#13237 closed bug (invalid)

.attr fails for xml elements

Reported by: john@… Owned by: john@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.9.0
Keywords: Cc:
Blocked by: Blocking:

Description

When querying with Ajax to a url that returns xml, when reading an element's attribute's value using attr('attName') fails now with 1.9.0

Change History (5)

comment:1 in reply to:  description Changed 7 years ago by Jim

Replying to john@…:

When querying with Ajax to a url that returns xml, when reading an element's attribute's value using attr('attName') fails now with 1.9.0

I confirm this error.

comment:2 Changed 7 years ago by dmethvin

Owner: set to john@…
Status: newpending

We still need a test case; can either of you provide one using jsfiddle.net?

comment:3 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

comment:4 Changed 7 years ago by john@…

This is not closed! I gave you the steps to reproduce; I do not have to use some tool to tell you otherwise.

I will state it again. Query via ajax a url that returns xml Find an element that has attributes. Read one of the attributes with .attr(name) You will see the error

How more simpler of a test case do you need?

comment:5 Changed 7 years ago by dmethvin

A sentence is generally not a good substitute for code. If you are unable to provide a complete test case in JavaScript that fails, please try your page with http://code.jquery.com/jquery-git.js and let us know if it still fails.

Note: See TracTickets for help on using tickets.