Bug Tracker

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#13192 closed bug (duplicate)

$(window).height() and $(window).width() returning 0 in IE9

Reported by: law@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.8.3
Keywords: Cc:
Blocked by: Blocking:

Description

From jquery version 1.8.0 and above $(window).height() and $(window).width() returns 0 in IE9. It works in Firefox however.

Please see these examples: https://www.defgo.net/demo/201301/1.7.0jquery.min.html (works correctly)

https://www.defgo.net/demo/201301/1.7.2jquery.min.html (works correctly)

https://www.defgo.net/demo/201301/1.8.0jquery.min.html (does not work, returns 0 in IE9)

https://www.defgo.net/demo/201301/1.8.3jquery.min.html (does not work, returns 0 in IE9)

Change History (4)

comment:1 Changed 6 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #12388.
You're in quirks mode. jQuery doesn't support quirks mode. Never has supported quirks mode. The jQuery Migrate plugin would tell you you're in quirks mode, you could use that.

comment:2 Changed 6 years ago by law@…

You are right about me being in quirks mode. (it works if I change it to e.g. IE9 Standards).

But you did previously (in 1.7.2 and earlier) support quirks mode (or at least the $(window).height() and $(window).width() worked correctly in quircks mode under those versions).

comment:3 Changed 6 years ago by dmethvin

There is a big difference between supporting something and it happening to work.

comment:4 Changed 6 years ago by law@…

True

Note: See TracTickets for help on using tickets.