Bug Tracker

Opened 6 years ago

Closed 6 years ago

#13149 closed bug (duplicate)

Inconsistent browser behavior when using $.ajax with dataType "script" and invalid "url"

Reported by: ipernet Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.8.3
Keywords: Cc:
Blocked by: Blocking:

Description

Simple repro:

http://ksimon-test.beta.svn.krds.com/jq.html

Actual result:

  • The error callback is not executed by Firefox or Chrome when using dataType: "script" with $.ajax and with a 404 URL (or any other HTTP error)
  • IE8+ executes the success callback, despite the url returns a 404 error.

Expected result:

Error callback should get executed if the URL cannot be loaded when using dataType: "script" for all browsers.

Or at least IE should not execute the success callback in such case.

Change History (1)

comment:1 Changed 6 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #12362.

Note: See TracTickets for help on using tickets.