Bug Tracker

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#13147 closed bug (duplicate)

.offset() calculation wrong on Windows Phone 8 when zoomed in

Reported by: speednet Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.8.3
Keywords: Cc:
Blocked by: Blocking:

Description

I am testing Windows Phone 8 on an HTC 8X from Verizon Wireless.

I am using jQuery 1.8.3.

The top and left coordinates are calculated correctly for an element when no zoom is applied to the screen, but when you use the pinch to zoom feature to make an area of the screen larger, all top and left .offset() calculations are wrong.

Change History (3)

comment:1 Changed 6 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #5565.
I suspect this is unfixable on our end if it is similar to the other position/offset issues on desktop browsers. I'll mark it as a dup. See #10488, #5565, #4993, #4724.

comment:2 Changed 6 years ago by speednet

No, this is NOT unfixable. I created a fix on my own, and it is as simple as calculating the offset like this: http://www.quirksmode.org/js/findpos.html

This needs to be re-opened and fixed. It is not difficult.

comment:3 Changed 6 years ago by dmethvin

The dup ticket is patchwelcome, you're welcome to submit a patch along with tests.

Note: See TracTickets for help on using tickets.