Bug Tracker

Opened 7 years ago

Closed 7 years ago

#13060 closed bug (invalid)

problem with method $.post y el symbol <

Reported by: lehernandezsuarez@… Owned by: lehernandezsuarez@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.8.3
Keywords: Cc:
Blocked by: Blocking:

Description

$.post(pagina,{accion : 'GESTION', permanente : 'prueba < interrupted'},function(respuesta){

$('#gestion').html(respuesta);

});

The problem is this: you can not send the less than symbol (<), by the method $. Jquery post. Removes words that are to the right.

In the above example the string 'test <interrupted', the word will be removed interrupted .......

and if the less than (<) is found at the beginning, the entire word is removed .........

emptied the post arrives .....

Change History (2)

comment:1 Changed 7 years ago by Rick Waldron

Owner: set to lehernandezsuarez@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket!

Additionally, be sure to test against the "jQuery (edge)" version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to begin.

comment:2 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.