Bug Tracker

Opened 7 years ago

Closed 7 years ago

#12993 closed bug (invalid)

jquery, on, event target

Reported by: fingerpasser Owned by: fingerpasser
Priority: undecided Milestone: None
Component: unfiled Version: 1.8.3
Keywords: Cc:
Blocked by: Blocking:

Description

html:

<ul>

<li><span>001</span></li> <li><span>002</span></li> <li><span>003</span></li>

</ul>

js: $(document).on('click','li',functioin(e){ why the e.target is span, not li, and how can i get the li without change the html. });

Change History (3)

comment:1 Changed 7 years ago by Rick Waldron

Owner: set to fingerpasser
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket.

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to get started.

comment:2 Changed 7 years ago by anonymous

I believe this is expected behaviour.

in the example, within the handler function 'this' will be a reference to the 'li' element, but the event target ('e.target') IS the span.

comment:3 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.