Bug Tracker

Opened 6 years ago

Closed 6 years ago

#12977 closed bug (duplicate)

use getAttribute to access swfobject's attribute in IE9

Reported by: Niphor Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.8.3
Keywords: Cc:
Blocked by: Blocking:

Description

jQuery has some bug when try to access swfobject's attribute use getAttribute in IE9.

it occurs: when use $("[someAttr=someNumber]") like $("[someAttr=12345]"); when use .remove() to remove a div contains swfobject; when a div contains swfobject ,and use .draggable() on it.

I tested swfupload & uploadify flash version,it shows the same bug.

there is my test page: http://jsfiddle.net/Niphor/ejLPk/

you can see some example in it.

Sorry for my poor English. Thank you.

Change History (2)

comment:1 Changed 6 years ago by Niphor

jQuery has some bug when try to access swfobject's attribute use getAttribute in IE>=9.

it occurs:
when use $("[someAttr=someNumber]") like $("[someAttr=12345]");
when use .remove() to remove a div contains swfobject;
when a div contains swfobject ,and use .draggable() on it.

I tested swfupload & uploadify flash version,it shows the same bug.

here is my test page: http://jsfiddle.net/Niphor/ejLPk/

you can see 2 examples in it.

I fond that there are some tickets reported the same bug 1 year ago ,and never fixed...
#12945
#12640
#10788

Sorry for my poor English. Thank you.

comment:2 Changed 6 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #12945.
That is too much code for a bug report. Please provide a test case that only includes jQuery core. To debug that much code, please go to a forum and ask for help. Also the site demo.swfupload.org does not seem to be responding so I cannot run your test case on jsFiddle.

I will close this as a dup of #12945 which does not yet have a response, please post your reduced test case there.

Note: See TracTickets for help on using tickets.