Bug Tracker

Opened 6 years ago

Closed 6 years ago

#12935 closed bug (duplicate)

Ajax data encoding ignored when passing data in as map

Reported by: christian.weder@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.8.3
Keywords: Cc:
Blocked by: Blocking:

Description

When creating an ajax request with a different encoding than UTF-8 and using a map for the data option, the ajax encoding is being ignored while converting the map to a query string. This is probably due to the fact that the jquery.param method that is used to convert the map to a query string uses the javascript method encodeURIComponent which creates an UTF-8 encoded representation of the parameters.

Change History (1)

comment:1 Changed 6 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #11097.

Note: See TracTickets for help on using tickets.