Bug Tracker

Opened 7 years ago

Closed 6 years ago

#12862 closed bug (cantfix)

Event propagation halted when synchrounous ajax call happens within an event

Reported by: drew.waddell Owned by: drew.waddell
Priority: undecided Milestone: None
Component: unfiled Version: 1.8.2
Keywords: Cc:
Blocked by: Blocking:

Description

This is an odd issue. I have done lots of debugging to try to figure out what is actually occurring but I have not figured it out.

This is an issue in Firefox, Internet Explorer handles the events perfectly. I have not tried any other browser.

I am not sure if this is an issue somewhere in the synchronous code, or if there is a Firefox setting I am unaware of such as a event timeout, or a Firefox bug.

jsFiddle: http://jsfiddle.net/dwaddell/dAj7B/
Screen Capture video: http://dl.dropbox.com/u/5126043/ScreenCapture_11-7-2012%201.38.52%20PM.wmv

Steps to reproduce:

  1. Bring up Firebug
  2. Click in the first textarea, an async request is fired, no issue ever happens
  3. Click in the second textarea, a sync request is fired, notice if the sync ajax request takes ~70ish ms to respond the next click out of the textarea will not trigger, else there is no issue

I added the link to the video because I understand the issue is rather odd and it may be confusion follow the steps to reproduce, I am hoping that with both it will be easy to reproduce.

Thanks for looking, Drew

Change History (8)

comment:1 Changed 7 years ago by dmethvin

Owner: set to drew.waddell
Status: newpending

Don't count out the possibility that Firebug is affecting the browser. Try disabling all plugins and see if the behavior changes. From the description it seems like this may be a Firefox issue that they would have to fix. Can you create a test case with plain XHR and addEventListener to rule out jQuery code?

comment:2 Changed 7 years ago by drew.waddell

Status: pendingnew

jsFiddle: http://jsfiddle.net/dwaddell/xSBxW/14/

I've removed the jQuery part for the second textarea, I seem to still be getting the issue. I didn't remove all the jQuery though, should I do that or do you think that is overkill?

Thanks, Drew

comment:3 Changed 7 years ago by drew.waddell

Also, I tried with plugins disabled, no Firebug running. It was still an issue.

comment:4 Changed 7 years ago by dmethvin

Resolution: notabug
Status: newclosed

Sorry but this is much too complex at the moment to be called a bug with jQuery core. You'll need to reduce this to something simpler. It might also be useful to try making a jQuery-free example to see if it really is a Firefox bug.

comment:5 Changed 6 years ago by cmcnulty

For the record, I hit this bug, and can confirm that it is a Firefox bug:

http://jsfiddle.net/cmcnulty/h9RDT/

The bug's been reported at least once that I can find - current status is unconfirmed:

https://bugzilla.mozilla.org/show_bug.cgi?id=636171

comment:6 Changed 6 years ago by anonymous

I filed a bug report for this at Mozilla as well: https://bugzilla.mozilla.org/show_bug.cgi?id=810691

Last edited 6 years ago by dmethvin (previous) (diff)

comment:7 Changed 6 years ago by dmethvin

Resolution: notabug
Status: closedreopened

comment:8 Changed 6 years ago by dmethvin

Resolution: cantfix
Status: reopenedclosed

I can't think of a workaround, so I'll change the resolution accordingly. Thanks for the bugzilla reference cmcnulty!

Note: See TracTickets for help on using tickets.