Bug Tracker

Opened 6 years ago

Closed 6 years ago

#12849 closed bug (duplicate)

Select status disappears when cloning select fields

Reported by: marco.behr@… Owned by:
Priority: undecided Milestone: None
Component: manipulation Version: 1.8.2
Keywords: Cc:
Blocked by: Blocking:

Description

Demo Page: http://jsfiddle.net/marcobehr/p99V5/ Testet on 1.8.2

When cloning a select field ...

<select id="testSelection">
        <option value="a">a</option>
        <option value="b">b</option>
        <option value="c">c</option>
    </select>

... and accessing its selected option after cloning, its selected value becomes reseted (always is equal to its first option).

var clone = jQuery("#testSelection").clone();

Now, when getting is selected option ...

var selCloneText = jQuery(clone).find(":selected").text();

... its always equal to the first option field, no matter what has been selected before.

Perhaps its a bug? For me it seems to be, because accessing radio fields in a similar way works as aspected.

Thanks!

Change History (1)

comment:1 Changed 6 years ago by timmywil

Component: unfiledmanipulation
Resolution: duplicate
Status: newclosed

Duplicate of #12479.

Note: See TracTickets for help on using tickets.