Bug Tracker

Opened 6 years ago

Closed 6 years ago

#12798 closed feature (wontfix)

.holdReady(true) after ready event

Reported by: david71rj Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.8.2
Keywords: Cc:
Blocked by: Blocking:

Description

Well, on API told that after ready event starts .holdReady() will not works anymore. But some times it is need. So it is a feature request, and not a bug.

For instance: I have two differents scripts. The first does an AJAX call, but it need stop ready event because the content get by AJAX need to exists before the next script.

An option, for me, is put the second jQuery.ready() inner the AJAX .success(), but it is ugly and hackish for my case (I need load the second script in all pages needless).

Example: http://jsfiddle.net/SuPe3/1/

Change History (1)

comment:1 Changed 6 years ago by dmethvin

Resolution: wontfix
Status: newclosed

Sorry, but .holdReady() itself is already ugly and hackish. If your needs are more complex than that, consider using something like AMD.

Note: See TracTickets for help on using tickets.