Bug Tracker

Opened 7 years ago

Closed 7 years ago

#12784 closed bug (duplicate)

Selector :checked selects not only checkboxes and radio buttons like mentioned in docs

Reported by: romull@… Owned by:
Priority: undecided Milestone: None
Component: selector Version: 1.8.2
Keywords: Cc:
Blocked by: Blocking:

Description

It's possible that claims stated in the jQuery dos are inconsistent, but usage of the :checked selector yields incorrect results if on the queried form element resides select element while documentation is saying that: The :checked selector works for checkboxes and radio buttons. For select elements, use the :selected selector. Working code snippet is here: http://jsfiddle.net/J7Quh/1/ This behaviour can be reproduced on versions 1.6.4 ... 1.8.2.

Change History (2)

comment:1 Changed 7 years ago by romull@…

Please, use this jsfiddle http://jsfiddle.net/J7Quh/3/

comment:2 Changed 7 years ago by timmywil

Component: unfiledselector
Resolution: duplicate
Status: newclosed

Duplicate of #12704.

Note: See TracTickets for help on using tickets.