Bug Tracker

Opened 13 years ago

Closed 13 years ago

#1275 closed bug (worksforme)

.loadIfModified() won't work in FF2.0

Reported by: kklou Owned by:
Priority: major Milestone: 1.2.2
Component: ajax Version: 1.1.2
Keywords: .loadIfModified() Cc:
Blocked by: Blocking:

Description

In FF2.0, the .loadIfModifed() did not show the ajax return data, but displayed the original content only. The same coding worked well in IE6, Opera 9.02.

coding as following: $("#SiteInfo .Content a").click(function(){ $("#Console .Content").loadIfModified(this.href);return false;});

when the anchor is clicked, the #Console.Contentn should display the ajax return content. IE6 Opera9.02 works well. But FF2.0 display the original content instead of the ajax return content.

If the .loadIfModified() changed to .load(), no problem encounted.

Attachments (2)

jquery_test.html (917 bytes) - added by davidserduke 13 years ago.
test case (based on description)
load.html (53 bytes) - added by davidserduke 13 years ago.
data for test case

Download all attachments as: .zip

Change History (3)

Changed 13 years ago by davidserduke

Attachment: jquery_test.html added

test case (based on description)

Changed 13 years ago by davidserduke

Attachment: load.html added

data for test case

comment:1 Changed 13 years ago by davidserduke

Milestone: 1.1.31.2.2
need: ReviewTest Case
Resolution: worksforme
Status: newclosed

I wasn't able to reproduce this in the current version 1.2.1 (with the above test case I created) so I'm going to mark it as works for me. So if you have a test case that fails please reopen the bug and attach it.

BTW, the function

.loadIfModified("load.html")

no longer works and instead would be called like

  $.ajax({ url:"load.html", ifModified:true });
Note: See TracTickets for help on using tickets.