Bug Tracker

Opened 6 years ago

Closed 6 years ago

#12732 closed feature (duplicate)

hasAttr

Reported by: markel Owned by:
Priority: low Milestone: None
Component: attributes Version: 1.8.2
Keywords: 1.9-discuss Cc:
Blocked by: Blocking:

Description

This is duplicate of #4324 and #9396. You already voted on #9396, deciding to say no, but i was told to bring this up again, when 1.9 will be around the corner.

To summarize –

Pros

Cons

  • Yes it's faster, but in what real world application it could be a bottleneck?
  • One more method to support and maintain
  • Hit on size (75 bytes)

Change History (6)

comment:1 Changed 6 years ago by timmywil

Component: unfiledattributes
Keywords: 1.9-discuss added
Priority: undecidedlow
Status: newopen
Version: git1.8.2

comment:2 Changed 6 years ago by timmywil

+0

comment:3 Changed 6 years ago by timmywil

In 2.0, the native .hasAttribute would work fine. However, if we want to make it "jQueryified", we could wrap it in hasAttr with an each. If we do that though, we should have the same, but cross-browser, API in 1.9. I'm fine either way.

comment:4 Changed 6 years ago by mikesherov

+0, I like small, but I also like fast.

comment:5 Changed 6 years ago by markel

i tried to make it as small as possible, i hope those 75 bytes would not be a deciding point in this.

Given that some edge-cases bugs take up to 40 bytes and all those gibson optimizations and future deprecated stuff that will be removed in 1.9 and a lot (a lot) of stuff that will be removed in 2.0 will give some perspective.

comment:6 Changed 6 years ago by Rick Waldron

Resolution: duplicate
Status: openclosed

Duplicate of #9396.

Note: See TracTickets for help on using tickets.