Bug Tracker

Opened 7 years ago

Closed 7 years ago

#12730 closed bug (worksforme)

JQuery adds indexOf to arrays in IE8

Reported by: serhiy.prysyazhnyy@… Owned by: serhiy.prysyazhnyy@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.8.2
Keywords: Cc:
Blocked by: Blocking:

Description

i have existing functionality with following code: for (var ind in container) { var val = container[ind]; ProcessValue(val); }

Now when I updated jquery, this code fails, because first index, found in object will be 'indexOf'.

Reproduced only in IE8;

Change History (3)

comment:1 Changed 7 years ago by timmywil

Owner: set to serhiy.prysyazhnyy@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket.

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/. Open the link and click to "Fork" (in the top menu) to get started.

comment:2 Changed 7 years ago by serhiy.prysyazhnyy@…

Status: pendingnew

Here is sample http://jsfiddle.net/DsTVd/4/ But this issue is not reproduced on JQuery(edge). Looks like I should update JQuery, it is already fixed.

comment:3 Changed 7 years ago by Rick Waldron

Resolution: worksforme
Status: newclosed
Note: See TracTickets for help on using tickets.