Bug Tracker

Opened 7 years ago

Closed 7 years ago

#12714 closed bug (duplicate)

.on(event, SELECTOR, callback) on SVG elements breaks with class selector

Reported by: norman.pellet@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.8.2
Keywords: Cc:
Blocked by: Blocking:

Description

http://jsfiddle.net/tuZax/1/

Works with 1.7.2, broken with 1.8.2

Event: Mouse over the rectangle Expected behaviour: Two console logs (Hovered By Element and Hovered By Class) Behavious in jQ 1.8.2: Only Hovered By Element is triggered

In other words: with the selector "rect", it works in both versions with the selector ".myRect", it works only in 1.7.2

Change History (2)

comment:1 Changed 7 years ago by norman.pellet@…

PS: Bug is not webkit / gecko dependent

comment:2 Changed 7 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #12626.
See #12626 for the workaround. SVG is not DOM or HTML.

Note: See TracTickets for help on using tickets.