Bug Tracker

Opened 15 years ago

Closed 15 years ago

Last modified 14 years ago

#1267 closed bug (fixed)

$("#bodyForm") does not work in ie

Reported by: atreeyang Owned by:
Priority: major Milestone: 1.1.3
Component: core Version: 1.1.2
Keywords: $(elementId) Cc:
Blocked by: Blocking:

Description

a html file as follows:

======================================================= <html>

<head> <title> bug </title> <script type="text/javascript" src="jquery.js"></script> </head>

<body>

<form id="bodyForm" name="haha"> <input name="id" type="hidden" value="2" /> <a href="#" onclick="alert($('#bodyForm').html())" >ok</a> </form>

</body> </html> =========================================

with a simple form, and a hidden input named "id"(<input name="id" type="hidden" value="2" /> ), the script $('#bodyForm').html() does not work(return null).

However, if i changed the input's name, for example --- <input name="test" type="hidden" value="2" /> , then all work well.

This only problem is only found in ie, firfox works well.

Change History (1)

comment:1 Changed 15 years ago by brandon

Component: ajaxcore
Priority: criticalmajor
Resolution: fixed
Status: newclosed

Duplicate of #1169 which is already fixed.

Note: See TracTickets for help on using tickets.