Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#12626 closed bug (wontfix)

Binding to SVG nodes with a class selector broken by 1.8.2

Reported by: jesse@… Owned by:
Priority: low Milestone: None
Component: event Version: 1.8.2
Keywords: Cc:
Blocked by: Blocking:

Description

The same event binding works in 1.8.1, but not in 1.8.2. In this example, the circle should turn red on hover:

jQuery 1.8.1: http://jsfiddle.net/3aEcw/

jQuery 1.8.2: http://jsfiddle.net/mvFrJ/

Change History (6)

comment:1 Changed 7 years ago by jesse@…

(I confirmed the issue on Chrome 22, WebKit Nightly, and FireFox 15.)

comment:2 Changed 7 years ago by dmethvin

See #10791 and use [class="classname"] instead.

http://jsfiddle.net/mvFrJ/1/

Keeping this open because I'm not sure what changed between 1.8.1 and 1.8.2, since we had closed it wontfix long ago.

Version 0, edited 7 years ago by dmethvin (next)

comment:3 Changed 7 years ago by mikesherov

Component: unfiledevent
Priority: undecidedlow
Resolution: wontfix
Status: newclosed

Unfortunately, we don't support SVG, and even though this worked in the past, it's not something we're supporting so we're not going to fix it for now. If we decide to support SVG in the future, we'll reopen and address this issue.

Thanks!

http://docs.jquery.com/Won't_Fix#SVG.2FXML.2FVML_Bugs

comment:4 Changed 7 years ago by dmethvin

#12714 is a duplicate of this ticket.

comment:5 Changed 7 years ago by gibson042

#13231 is a duplicate of this ticket.

comment:6 Changed 7 years ago by gibson042

#13420 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.