Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#12586 closed bug (duplicate)

IE7 Iframe content class selector not working

Reported by: mnovacek@… Owned by:
Priority: undecided Milestone: 1.8.2
Component: selector Version: 1.8.1
Keywords: Cc:
Blocked by: Blocking:

Description

This works in IE7 $v1.7.2 but does not in $v1.8.1

$('#submit_frame').contents().find('.paging_info .current').text();

Running find with classname selector on iframe content seems to be the issue.

But hey, it is IE7. Let it rot.

Change History (3)

comment:1 Changed 7 years ago by gibson042

Component: unfiledselector
Milestone: None1.8.2
Resolution: duplicate
Status: newclosed

Duplicate of #12572.

comment:2 Changed 7 years ago by gibson042

Fixed in 1.8.2. Also, please provide a functional reduced test case demonstrating the issue (we like jsFiddle and JS Bin) when reporting bugs on this tracker.

comment:3 Changed 7 years ago by ted.rakers@…

Hello,

I have another issue with IE7 and Iframes. Unfortunatly we have many desktops still using IE7 :( and I totally did not took it into consideration. Next selector does not work: 'a[style='mso-comment-reference: MO_1']'

Below is the jsFiddle. The jsFiddle should work in IE8 but currently gives a 'Display' error: http://jsfiddle.net/qUXD7/3/ The iframe in this fiddle is cross domain for demo purposes but the iframe in my environment is in the same domain.

I hope you can help out!

Note: See TracTickets for help on using tickets.