Bug Tracker

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#1258 closed bug (duplicate)

Functionality Changed regarding Fade

Reported by: bgoldman Owned by:
Priority: major Milestone: 1.1.3
Component: effects Version: 1.1.2
Keywords: Cc:
Blocked by: Blocking:

Description (last modified by brandon)

[12:16] bgoldman86: i put an alert in jquery.js and i found the bug. it could be a feature. but regardless, its inconsistent with 1.1.2

[12:17] bgoldman86: #box returns true for ishidden, and is trying to show (fadein), so returns instead of queueing the animation

[12:17] bgoldman86: within animate()

[12:18] bgoldman86: blah returns false for ishidden

[12:18] johnresig: could you mock up a demo?

[12:18] bgoldman86: yeah

[12:19] bgoldman86: am i using fadeIn property? ive never had this issue before. when fading in an element for the first time, am i supposed to set its opacity to 0 first?

[12:19] johnresig: no

[12:20] bgoldman86: then it seems the bug is obvious. by cancelling the animation if opacity=show and hidden=false, youre not allowing fadeIns for elements that dont have 0 opacity

[12:21] johnresig: well, fadeIns would only ever work for elements that were hidden

[12:21] johnresig: opacity=0 != hidden

[12:22] bgoldman86: so i have to hide() it first?

[12:22] johnresig: you can't fadeIn something that isn't hidden to begin with

[12:22] johnresig: right

[12:22] johnresig: this was actually a bug fix, in that respect

[12:23] bgoldman86: hmmm. in that case, the bug was in 1.1.2? because my code works with that lib

[12:23] bgoldman86: lol

[12:24] bgoldman86: well, i guess i dont need to submit a bug report

[12:25] johnresig: submit a bug report saying "this functionality changed, therefore it should be documented better

[12:25] bgoldman86: k

Change History (2)

comment:1 Changed 14 years ago by brandon

Component: ajaxfx
Description: modified (diff)

comment:2 Changed 14 years ago by brandon

Resolution: duplicate
Status: newclosed

duplicate of #1214

Note: See TracTickets for help on using tickets.