Bug Tracker

Opened 7 years ago

Closed 7 years ago

#12579 closed bug (wontfix)

label click does not forward to input on Firefox 4

Reported by: eliasew@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.8.1
Keywords: Cc:
Blocked by: Blocking:

Description

On old versions of Firefox, jQuery click()-ing an input's label does not fire click handlers on the input. Manual mouse clicks works as intended.

http://jsfiddle.net/PqpDc/1/ should alert but does not in:
Windows 7 Firefox: 3.5.16, 3.6.28 or 4.0
Debian Squeeze Iceweasel: 3.5.16

alert fires as it should in:
Windows 7 Firefox: 5.0, 7.0, 11.0 or 14.0.1

jQuery 1.3.2 through 1.8.1 shows the same behaviour.

Change History (1)

comment:1 Changed 7 years ago by dmethvin

Resolution: wontfix
Status: newclosed

We support Firefox 15, 14 and 10 ESR. Glad to know it works there. You should upgrade from earlier versions since they are no longer supported by Mozilla. If you require support for those versions you can manually add click handlers to the labels.

Note: See TracTickets for help on using tickets.