Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#12543 closed bug (duplicate)

Large selector performance regression

Reported by: r.m.graham@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.8.1
Keywords: Cc:
Blocked by: Blocking:

Description

I have a CRUD app (aka html with large tables) that was hit pretty hard with this. We updated to 1.8.1 and suddenly there were 4 second delays when users click a checkbox before it would be checked.

I managed to reduce the test case pretty significantly on jsbin:

http://jsbin.com/ubavob/3/edit

The problem came down to, more or less, this:

$(document).on("click",
               "tr[link] td:not(:has(a,input)), td[link]",
               function() { /* ... */});

It's not great code, but the 100x slow down is worse.

Change History (3)

comment:1 Changed 7 years ago by timmywil

Resolution: duplicate
Status: newclosed

Duplicate of #12436.

comment:2 in reply to:  1 Changed 7 years ago by r.m.graham@…

Replying to timmywil:

Duplicate of #12436.

Meta-bug/feature request: setting degradation and regression as search term synonyms would have saved me the day I spent reducing my test.

comment:3 Changed 7 years ago by dmethvin

Sorry...it's always hard to pick out the right terms in a search. It would be easier if there wasn't so much noise from people filing things that weren't bugs. Unfortunately that makes things that *are* bugs like yours harder to find.

Note: See TracTickets for help on using tickets.