Bug Tracker

Opened 7 years ago

Closed 7 years ago

#12524 closed bug (duplicate)

Stackoverflow error when selector contains :Eq (ex $(":input[data="value:Equivalent"]") )

Reported by: iulian@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.8.1
Keywords: Cc:
Blocked by: Blocking:

Description

Example jsFiddle: http://jsfiddle.net/h9VRc/2/

Results in error: Uncaught RangeError: Maximum call stack size exceeded

Apparently the problem is in the select function:

POS handling if (matchExprPOS?.test(selector)) {

return handlePOS(match, context, results, seed);

}

where the regex is : /:(nth|eq|gt|lt|first|last|even|odd)(?:\(((?:-\d)?\d*)\)|)(?=[-]|$)/gi

which matches selectors that contain "unintended" pseudo selectors like the one in the summary.

Change History (1)

comment:1 Changed 7 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #12303.

Note: See TracTickets for help on using tickets.