Bug Tracker

Opened 7 years ago

Closed 7 years ago

#12512 closed bug (duplicate)

IE8/IE9 no longer fires "change" event when pressing enter key in a text box

Reported by: dos-one Owned by:
Priority: high Milestone: 1.next
Component: event Version: 1.8.0
Keywords: Cc:
Blocked by: Blocking:

Description

See http://jsfiddle.net/6dazt/4/

Basically the change event no longer fires in IE when you hit the enter key inside a text box. Blur appears to fire the event still, but not the enter key.

This appears to be an issue in 1.7.2 as well, so I'm not sure if I'm doing something wrong or what?

Change History (6)

comment:1 Changed 7 years ago by timmywil

Component: unfiledevent
Priority: undecidedlow
Resolution: cantfix
Status: newclosed

I don't think this is something we can control. I'd suggest checking for change on keypress or keyup.

comment:2 in reply to:  1 Changed 7 years ago by dos-one

Replying to timmywil:

I don't think this is something we can control. I'd suggest checking for change on keypress or keyup.

How come it works in jQuery 1.6.x but not 1.7 or 1.8??

comment:3 Changed 7 years ago by timmywil

Resolution: cantfix
Status: closedreopened

Ah, didn't realize that. Well, then it must be our handling of delegating the change event.

comment:4 Changed 7 years ago by timmywil

Milestone: None1.next
Priority: lowhigh
Status: reopenedopen

comment:5 Changed 7 years ago by dos-one

Thanks for scheduling this!

comment:6 Changed 7 years ago by dmethvin

Resolution: duplicate
Status: openclosed

Duplicate of #11556.
It works in 1.6.x because it didn't use the IE change event at all. That caused many bugs. This is a bug on the other side of the pendulum swing, but given the issues (see other ticket) I think we'll have to live with it.

Last edited 7 years ago by dmethvin (previous) (diff)
Note: See TracTickets for help on using tickets.