Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#12510 closed bug (duplicate)

Delegated events are much slower in IE 7/8 with 1.8.1 than with 1.7.2

Reported by: simon.brent@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.8.1
Keywords: Cc:
Blocked by: Blocking:

Description

If you have a large number of elements with delegated events attached, and the original bound element also has other delegated events, performance in IE 7/8 (I haven't tested 6, and 9 is fine) is much slower than it used to be.

See the following tests:

http://jsbin.com/iyacim/1/edit (1.7.2)

http://jsbin.com/uxovuh/1/edit (1.8.1)

When you click on any of the spans saying "Click here", a red box will appear instantly in 1.7.2, but it takes much longer to do so in 1.8.1.

This still happens if all the click functions return false.

Change History (2)

comment:1 Changed 7 years ago by mikesherov

Resolution: duplicate
Status: newclosed

Duplicate of #12436.

comment:2 Changed 7 years ago by anonymous

Ah, sorry...I searched but didn't find!

Note: See TracTickets for help on using tickets.