Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#12470 closed bug (invalid)

Exposing chrome JS objects to content without __exposedProps__ is insecure and deprecated.

Reported by: rudeboiidevil2k7@… Owned by: rudeboiidevil2k7@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.8.1
Keywords: Cc:
Blocked by: Blocking:

Description

I am getting an error logged in Firebug in an hover event, but the problem is in jQuery, I am using Firefox 15.0 on Mac OS X Lion.

Exposing chrome JS objects to content without __exposedProps__ is insecure and deprecated. See https://developer.mozilla.org/en/XPConnect_wrappers for more information.

Which is on line 322, in jQuery 1.8.1. I don't know why this is being logged in Firebug.

Change History (10)

comment:1 Changed 7 years ago by timmywil

Owner: set to rudeboiidevil2k7@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket.

Additionally, be sure to test against the jQuery git("edge") version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/. Open the link and click to "Fork" (in the top menu) to get started.

comment:2 Changed 7 years ago by sami

I see this as well.

comment:3 Changed 7 years ago by dmethvin

Great sami! Can you post the requested test case? That would help us a lot.

comment:4 Changed 7 years ago by ben

I'm trying to create a test case for you, but I'm not sure where in a lot of detailed code this error is being triggered, and Firebug's stack trace just produces an unhelpful reference to minified JQuery. Any hints as to how to track down the call that generates the error?

comment:5 Changed 7 years ago by dmethvin

Well, the message itself seems to indicate it may be coming from a plugin. So I'd suggest you run with all plugins disabled and see if it goes away.

http://support.mozilla.org/en-US/kb/troubleshoot-issues-with-plugins-fix-problems

If it's a plugin then you'd need to contact them.

comment:6 Changed 7 years ago by emilper@…

no, it's not from plugins: is is something about the Ajax calls

I get these

Timestamp: 09/07/2012 10:49:03 AM Error: Exposing chrome JS objects to content without exposedProps is insecure and deprecated. See https://developer.mozilla.org/en/XPConnect_wrappers for more information. Source File: chrome://mozapps/content/downloads/unknownContentType.xul Line: 1

even when no plugin is installed, when doing Ajax calls

comment:7 Changed 7 years ago by mata987@…

Seams that it is a problem with FireQuery add-on for Firefox, and not jQuery.

More info on the following link: https://blog.mozilla.org/addons/2012/08/20/exposing-objects-to-content-safely/

comment:8 Changed 7 years ago by dmethvin

Resolution: invalid
Status: pendingclosed

Yeah, a plugin.

comment:9 Changed 7 years ago by dmethvin

#12637 is a duplicate of this ticket.

comment:10 Changed 7 years ago by dmethvin

#12637 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.