Bug Tracker

Opened 7 years ago

Closed 7 years ago

#12446 closed bug (duplicate)

issue with $(window).height()

Reported by: jeanguy.buon@… Owned by: jeanguy.buon@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.8.0
Keywords: Cc:
Blocked by: Blocking:

Description

Hello,

I updated jQuery to 1.8.1 and have the foolowing issue: $(window).height() returns the height of the document (including scroll). Before this jQuery upgrade I only had the visible window height.

Could you please fix it?

Change History (5)

comment:1 Changed 7 years ago by dmethvin

Owner: set to jeanguy.buon@…
Status: newpending

It sounds like your page may be in Quirks mode, which jQuery does not support. Can you confirm?

comment:2 Changed 7 years ago by jeanguy.buon@…

Status: pendingnew

How can I check that?

Is that depending of doctype?

In my case it is: <!DOCTYPE HTML PUBLIC '-W3CDTD HTML 4.01 TransitionalEN'>

comment:4 Changed 7 years ago by jeanguy.buon@…

OK, my issue is from the doctype.

I'm having some extra issues using the doctype you suggest so I will fixe these little issues and use this new doctype definition.

You can close my ticket!

Regards,

comment:5 Changed 7 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #12388.
The simplest doctype is always <!doctype html> and kicks every browser into standards mode.

Note: See TracTickets for help on using tickets.