Bug Tracker

Opened 10 years ago

Closed 10 years ago

#12432 closed bug (duplicate)

Access is Denied error when wrapping HTML strings in IE 9

Reported by: cap10morgan Owned by: cap10morgan
Priority: low Milestone: None
Component: unfiled Version: 1.8.0
Keywords: Cc:
Blocked by: Blocking:

Description

In IE 9 on Windows 7, under some circumstances* when wrapping HTML strings to make them jQuery objects like this: $("<p>Test!</p>"), jQuery 1.8.0 fails with an Access is Denied error.

The same code works just fine under jQuery 1.7.2 in IE 9, and I haven't seen it happen on any other non-IE browser on any version of jQuery.

*It appears that the bug shows up on initial page load, but refreshing the page will make it go away.

Change History (4)

comment:1 Changed 10 years ago by sindresorhus

Owner: set to cap10morgan
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket.

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to get started.

comment:2 Changed 10 years ago by sindresorhus

Priority: undecidedlow

This might be related to #12282. Make sure you also test using jQuery edge.

comment:3 Changed 10 years ago by cap10morgan

Status: pendingnew

Looks like it may have already been fixed in edge: #12266.

comment:4 Changed 10 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #12266.
Thanks cap10morgan!

Note: See TracTickets for help on using tickets.