Bug Tracker

Opened 7 years ago

Closed 7 years ago

#12430 closed bug (invalid)

Chrome "selected" attributes not being correctly reflected

Reported by: tim@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.8.0
Keywords: Cc:
Blocked by: Blocking:

Description

jsFiddle: http://jsfiddle.net/trmackenzie/cvPhd/4/

I've come across an issue in Chrome and I can't tell if it's a bug with Chrome, a bug with jQuery, or an error in my code. I've search through open issues with Chromium and couldn't find anything and likewise with jQuery.

Expected: When I click on a radio button, the indicated values are selected in the options list. Also, if I click a specific option in the list, all radio buttons are deselected.

Actual (in Chrome 21 for Windows and Mac): Only the last desired option is selected when clicking a radio button for the first time and then subsequent clicks causes nothing to happen. If a specific option in the list is chosen, a radio button remains selected.

Actual (in IE7,8,9 and Firefox): Same as expected behavior, e.g. correct behavior.

Note that the "selected" attribute on the option(s) is being set correctly but Chrome stops displaying its state.

Is this jQuery related or Chromium related?

Change History (2)

comment:1 Changed 7 years ago by anonymous

Doh...have since been told not to use "removeProp"...documentation correctly warns about this... I've once again been thrown by the subtleties of attributes, properties, and how to change/remove them appropriately.

comment:2 Changed 7 years ago by dmethvin

Resolution: invalid
Status: newclosed

I'm sure everyone involved in the current W3C property-attribute mess wishes they had a time machine, no problem.

Note: See TracTickets for help on using tickets.