Bug Tracker

Opened 7 years ago

Closed 7 years ago

#12427 closed bug (invalid)

animation changes display property

Reported by: jkbailey@… Owned by: jkbailey@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

When performing a fadeIn animation on an element with a css property of "display: inline-block", the end result of the animation sets the style attribute of the element to "display: block", which overrules the property set in css, therefore causing issues with formatting animated elements.

P.S. however, browsers might try to fix this issue on their own (ie. in Chrome, its not an issue unless you pull up the print page dialog and then cancel it.)

Change History (3)

comment:1 Changed 7 years ago by dmethvin

Owner: set to jkbailey@…
Status: newpending

Although this is a cool story, it isn't something we can take action on yet. It would be really helpful to have a test case as well. Can you write up a simple test case and post it on jsFiddle.net or jsbin.com so we can see how to reproduce the problem?

comment:2 Changed 7 years ago by Rick Waldron

jQuery does it's best to use the default display type of an element — is your CSS overriding a default display?

comment:3 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.