Bug Tracker

Opened 13 years ago

Closed 11 years ago

#1240 closed bug (fixed)

XUL and .val(...), .attr('value', ...)...

Reported by: darh Owned by:
Priority: minor Milestone: 1.2.5
Component: core Version: 1.1.2
Keywords: xul attr value Cc:
Blocked by: Blocking:

Description

As I figured out, XUL documents are identified as XML documents (via isXMLDoc()) and that creates a problem when you want to operate with certain elements with jQuery in XUL (radio button, checkboxes, various lists etc).

The problem is with these lines:

var fix = jQuery.isXMLDoc(elem) ? {} : {
	"for": "htmlFor",
....
	selected: "selected"
};

The quick fix was to do this:

var fix = jQuery.isXMLDoc(elem) ? {value: "value"} : {
....
};

The quick overview of the code following the fix shows no big problems, but without any test/build environment for jQuery that is all I can do about it.

Change History (1)

comment:1 Changed 11 years ago by flesler

Milestone: 1.2.5
Resolution: fixed
Status: newclosed

This was probably fixed on 1.2.6 as this behavior changed.

Reopen if you see a fail.

Note: See TracTickets for help on using tickets.