Bug Tracker

Opened 7 years ago

Closed 7 years ago

#12390 closed bug (duplicate)

$.browser.webkit doesn't include Chrome anymore

Reported by: howellnick@… Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.8.0
Keywords: Cc:
Blocked by: Blocking:

Description

Starting in jQuery 1.8.0 the $.browser.webkit behavior changed.

Run these using Chrome: jQuery 1.8.0: http://jsfiddle.net/wjk8F/1/ jQuery 1.7.2: http://jsfiddle.net/wjk8F/2/

I see that Chrome got it's own $.browser.chrome detection in 1.8.0, but it should still be a webkit browser.

I'd like $.browser.webkit to be true if the browser is Chrome again. Instead, if I should be using the browser specific ones like $.browser.safari and $.browser.chrome just say so. Perhaps for the reason I don't see a $.browser.gecko, for example.

Change History (1)

comment:1 Changed 7 years ago by dmethvin

Resolution: duplicate
Status: newclosed

Duplicate of #12333.

Note: See TracTickets for help on using tickets.