Bug Tracker

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#12387 closed bug (invalid)

Regression document ready

Reported by: nicolas.penin@… Owned by: nicolas.penin@…
Priority: high Milestone: None
Component: core Version: 1.8.0
Keywords: Cc:
Blocked by: Blocking:

Description

I believe there is an issue document ready raised to early (in google chrome 21) : you can compare on this fiddle : http://jsfiddle.net/neonp/KCsub/

Change History (4)

comment:1 Changed 6 years ago by mikesherov

Owner: set to nicolas.penin@…
Status: newpending

Hi Nicolas,

Thanks for the test case. It's a bit too complex to accurate debug what's happening here, although I don't believe it's an issue with document readiness. Could you perhaps reduce the jsfiddle example down further so we can easily see the bug?

comment:2 Changed 6 years ago by Nicolas Penin <nicolas.penin@…>

Indeed however, I just find out that the issue is written clearly in the chrome console :

Uncaught Error: Syntax error, unrecognized expression: :not(:input))

comment:3 Changed 6 years ago by mikesherov

Component: unfiledcore
Priority: undecidedhigh
Resolution: invalid
Status: pendingclosed

Great, thanks for getting back. I believe it may be a duplicate of http://bugs.jquery.com/ticket/11355 . If not, please file a new bug with a further reduced test case. Thanks again!

comment:4 Changed 6 years ago by Nicolas Penin <nicolas.penin@…>

Actually, it is really a syntax error in where the previous version was maybe too permissive. Here is a reduced test case : http://jsfiddle.net/neonp/HLjtJ/

Note: See TracTickets for help on using tickets.