Bug Tracker

Opened 7 years ago

Closed 6 years ago

#12287 closed bug (duplicate)

Nested custom pseudo class selectors throw exceptions

Reported by: seddon.ryan@… Owned by:
Priority: low Milestone: None
Component: selector Version: 1.8.0
Keywords: Cc:
Blocked by: Blocking:

Description

See testcase http://jsfiddle.net/ryanseddon/PPuRg/1/

I came across this error while upgrading to 1.8, our site uses Microsofts MVC validation lib which builds a selector like this $("#ResumeValSummary:not(:has(ul:first))") this gets mangled inside the handlePOS method which passes the selector off as "#ResumeValSummary:not(:has(ul"

This happens for any of the custom pseudo-classes e.g. odd, even etc above test case covers more scenarios where this falls over.

Change History (2)

comment:1 Changed 7 years ago by sindresorhus

Cc: timmywil added
Component: unfiledselector
Priority: undecidedlow
Status: newopen

Confirmed. Worked in 1.7.2

comment:2 Changed 6 years ago by timmywil

Cc: timmywil removed
Resolution: duplicate
Status: openclosed

Duplicate of #12285.
This will be addressed in #12285.

Note: See TracTickets for help on using tickets.