Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#12284 closed bug (invalid)

$(window).height() is wrong

Reported by: anonymous Owned by: anonymous
Priority: low Milestone: None
Component: dimensions Version: 1.8.0
Keywords: Cc:
Blocked by: Blocking:

Description

Tested in Chrome.

In version 1.7.2: $(window).height(): 498 $(document).height(): 2348

In version 1.8.0: $(window).height(): 2348 $(document).height(): 2348

Change History (8)

comment:1 Changed 10 years ago by timmywil

Owner: set to anonymous
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket.

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/. Open the link and click to "Fork" (in the top menu) to get started.

comment:2 Changed 10 years ago by mikesherov

This ticket is fool's gold. I created a bug in 1.7.2 when I ambitiously tried to fix window.height() vs. document.height(), only to revert to the pre 1.7.2 behavior for 1.8

If the OP can kindly provide the a fiddle showing the results in 1.7.2 and 1.8.0 and 1.7.1, I'll investigate.

comment:3 Changed 10 years ago by anonymous

Status: pendingnew

This bug is very strange, it only seems to happen on certain pages.

You can replicate it like this: Go to

http://benalman.com/code/test/jquery-run-code-bookmarklet/?name=Run+jQuery+Code&ver=1.7.1&code=alert%28%5B%24%28window%29.height%28%29%2C+%24%28document%29.height%28%29%5D%29%3B%0D%0A

to create a bookmarklet for 1.7.1. Then go to http://news.ycombinator.com/ and run the bookmarklet.

Then go to

http://benalman.com/code/test/jquery-run-code-bookmarklet/?name=Run+jQuery+Code&ver=1.8.0&code=alert%28%5B%24%28window%29.height%28%29%2C+%24%28document%29.height%28%29%5D%29%3B%0D%0A

to create a bookmarklet for 1.8.0. Then go to http://news.ycombinator.com/ and run the bookmarklet.

It gives a different (wrong) result.

comment:4 Changed 10 years ago by mikesherov

Component: unfileddimensions
Priority: undecidedlow
Status: newopen

comment:5 Changed 10 years ago by timmywil

Status: openpending

It would be better to have a test case from jsfiddle or jsbin instead of a bookmarklet that we cannot manipulate.

comment:6 Changed 10 years ago by dmethvin

Resolution: invalid
Status: pendingclosed

I'm going to close this because news.ycombinator.com is in quirks mode. It's horrible practice but it's their right to do so, and they're not using jQuery.

comment:7 Changed 10 years ago by mikesherov

#12766 is a duplicate of this ticket.

comment:8 Changed 10 years ago by mikesherov

#12845 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.