Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#12257 closed bug (worksforme)

jquery Validation and Date Picker not working with Chrome new version (21.0.1180.75)

Reported by: ajaygupta2312@… Owned by: ajaygupta2312@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.8.0
Keywords: Cc:
Blocked by: Blocking:

Description

I have been using JQuery latest script and Validation Script on my forms. Since Thursday, none of JQuery Validations are working on Google Chrome. I found out that Chrome version is upgraded to 21.0.1180.75. All the validations are working fine in Friefox and IE. Also, date picker from Jquery is not working at all. It causing the page to go blank in New Chrome Version

Change History (5)

comment:1 Changed 7 years ago by Rick Waldron

Owner: set to ajaygupta2312@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket!

Additionally, be sure to test against the "jQuery (edge)" version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to begin.

comment:2 Changed 7 years ago by ajaygupta2312@…

Status: pendingnew

I am working on Salesforce platform and we are using jquery. I am not sure how can I test the code on jsfiddle. I can provide you simple apex code for testing.


<apex:page standardController="TISL_Script__c" extensions="TISLNewScriptController" id="thePage">

<apex:includeScript value="https://ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.js"/>

<apex:includescript value="http://ajax.microsoft.com/ajax/jquery.validate/1.9/jquery.validate.min.js"></apex:includescript>

<script type="text/javascript">

Rules

$(document).ready(function(){

$(".sendButton").click(function() {

$('[id$=submitForm]').validate();

$('[id$=firstname]').rules("add",{

required: true

});

});

});

</script>

<FORM action="" method="post" id="submitForm"> <P> <LABEL for="firstname">First name: </LABEL>

<INPUT type="text" id="firstname"/><BR/>

<LABEL for="lastname">Last name: </LABEL>

<INPUT type="text" id="lastname"/><BR/>

<INPUT type="submit" value="Send" class="sendButton" /> </P>

</FORM>

</apex:page>


Thanks Ajay

comment:3 Changed 7 years ago by Rick Waldron

Status: newpending

You can make that work by just including a reduced version of the markup and the offending JS. If it can't be reproduced, then it's not a bug in jQuery

comment:4 Changed 7 years ago by Rick Waldron

Resolution: worksforme
Status: pendingclosed

When I reduce it and move the actual rule setting outside of the submission handler, it works fine. http://jsfiddle.net/rwaldron/RFtb7/

The code above isn't even adding the rule until after the first click.

comment:5 Changed 7 years ago by ajaygupta2312@…

Thanks. Let me test it.

Note: See TracTickets for help on using tickets.