Bug Tracker

Opened 7 years ago

Closed 7 years ago

#12246 closed bug (invalid)

Animate :: Using '+=' or '-='

Reported by: joao.pinho@… Owned by: joao.pinho@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.8.0
Keywords: Cc:
Blocked by: Blocking:

Description

Hi,

I'm currently experiencing an issue with jquery animate, when doing the same actions too many times. Here is an example of the executing code:

$('.cbq-layout-main.channel .viewimage').click(function () {

if ($(this).hasClass('sel')) return false;

$(this).addClass('sel').siblings().removeClass('sel'); $('.cbq-layout-main.channel .description').stop().show()

.animate({ opacity: 1 });

$('.cbq-layout-main.channel .dfwp-item .item').stop()

.animate({ height: '+=70px' }, { queue: false });

return false;

});

$('.cbq-layout-main.channel .viewlist').click(function () {

if ($(this).hasClass('sel')) return false;

$(this).addClass('sel').siblings().removeClass('sel'); $('.cbq-layout-main.channel .description').stop()

.css({ opacity: 0 }).hide();

$('.cbq-layout-main.channel .dfwp-item .item').stop()

.animate({ height: '-=70px' }, { queue: false });

return false;

});

The HTML are a couple of divs with title and description, and i'm collapsing to show only the title, and achieve a more compact layout that allows me to show more content.

To make the divs collapse i have two links, the ones of the click event above, and the problem is that when i click repeatedly into collapse and expand for lets say 10 seconds the divs start getting unformatted, like, text instead of staying in its place starts shifting down a little bit out of the div, like this (ASCII IMAGE):

a\=========================\a a\ \a a\ \a a\ lorei ipsum bla bla bla \a a\ sdasds ds ad sd asd sa \a a\=========================\a

dsdasdsdsds sd asd sa d sadsd sad sad asdsd sa sadsadsadsads dasdsdsad

The text was initially inside the div... Is this a bug? Am i doing something wrong?

Please help me..

Best Regards,

João Pinho

Change History (2)

comment:1 Changed 7 years ago by timmywil

Owner: set to joao.pinho@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket.

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/. Open the link and click to "Fork" (in the top menu) to get started.

comment:2 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.