Bug Tracker

Opened 7 years ago

Closed 7 years ago

#12238 closed bug (duplicate)

Having multiple :not(:has()) selectors throws a syntax error.

Reported by: r.osenkonstantinov@… Owned by:
Priority: low Milestone: None
Component: selector Version: 1.8.0
Keywords: Cc: timmywil
Blocked by: Blocking:

Description

Having similar to the following selector fails with syntax error: $("div:not(:has(span.bar)):not(:has(a.baz))")

This seems to work with 1.7 version.

Here you can find simple repro: http://jsbin.com/orohus/1

Change History (3)

comment:1 Changed 7 years ago by addyosmani

Cc: timmywil added
Component: unfiledselector
Priority: undecidedlow

Confirmed, however I can't quite help but feel like the complexity of the selector you're using can be significantly simplified. I imagine this change is related to the Sizzle rewrite.

comment:2 Changed 7 years ago by mikesherov

This selector haunts my dreams. Godspeed, timmywil... We're all counting on you.

comment:3 Changed 7 years ago by timmywil

Resolution: duplicate
Status: newclosed

Duplicate of #12237.

Note: See TracTickets for help on using tickets.