Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#12196 closed bug (invalid)

Custom matchesSelector doesn't work in FF 3.6

Reported by: josh@… Owned by:
Priority: low Milestone: None
Component: selector Version: 1.8rc1
Keywords: Cc:
Blocked by: Blocking:

Description

This is a Sizzle bug specifically, but I'm not sure if this is the correct issue tracker.

Can be reproduced with a simple test case:

jQuery.find.matchesSelector($('input')[0], ':input')
// returns false

On old FF, invalid selectors passed to mozMatchesSelector would always return false instead of correctly throwing an exception. There used to be a feature detect in Sizzle to test for this.

// This should fail with an exception
// Gecko does not error, returns false instead
try {
  matches.call( div, "[test!='']:sizzle" );
  rbuggyMatches.push( Expr.match.PSEUDO );
} catch ( e ) {}

Change History (4)

comment:1 Changed 7 years ago by sindresorhus

Component: unfiledselector
Priority: undecidedlow
Resolution: invalid
Status: newclosed

Does this still happen with 1.8 final?

If yes, please create a jsfiddle testcase and report the issue on the Sizzle bug tracker.

comment:2 Changed 7 years ago by anonymous

Yes, 1.8 final is still broken.

https://github.com/jquery/sizzle/issues/142

comment:3 Changed 7 years ago by dmethvin

jQuery 1.8 doesn't support Firefox 3.6 since it's no longer supported by Mozilla as of April this year. Is there a reason you still need to support it, given that there are no security patches being created for example?

comment:4 Changed 7 years ago by anonymous

Thats fine. Just didn't see anything in the release notes about it.

Note: See TracTickets for help on using tickets.