Bug Tracker

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#12178 closed bug (duplicate)

Crash on IE8 in data.js' removeData function

Reported by: dwilks Owned by: dwilks
Priority: low Milestone: None
Component: effects Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

Browser: IE8, IE9 in IE8 mode Version: 1.7.1, 1.7.2 and jquery-git (2012-08-01)

Here's a full description of the issue: http://pdfcast.org/download/jquery-calendar-problem.pdf

The short version:

  • document.body has a jquery change event on it
  • when a jquery ui calendar's month select list is used to change the month
  • jquery crashes in (data.js) removeData as jqui is trying to replace the calendar

because the select list's removeAttribute property's type is unknown and just testing for causes an error.

} else if ( elem.removeAttribute ) {

  • the select list's removeAttribute starts out ok when the date picker is being created and jquery.append initially creates the fragment but becomes 'unknown' when it's actually appended to the document after

this.appendChild( elem );

This is the same issue as #9476. Of course a simple jsfiddle works fine. When the calendar is added to the document its month select list's removeAttribute remains typeof === object. I am going to try to keep whittling down my fail case and get it into a jsfiddle and in the mean time add a typeof test to our local version of jquery.

What I do know...

  • Fails in IE8 regardless of doctype
  • Works in IE9 with html5 doctype or with IE9 meta tag
  • Fails in IE9 with IE8 meta tag

Change History (6)

comment:1 Changed 7 years ago by timmywil

Owner: set to dwilks
Status: newpending

Thank you for taking the time to contribute to the jQuery project!

We will need a test case that does not include jQuery UI. If this is a bug in jQuery UI, please file a bug report at http://bugs.jqueryui.com.

comment:2 Changed 7 years ago by dwilks

Status: pendingnew

Here's the simple fail case: http://jsfiddle.net/ZpgGT/

The key conditions:

  • body must have a change event
  • the dynamically appended element must have an associated style with a behavior:url(#default#savehistory)

comment:3 Changed 7 years ago by timmywil

Component: unfiledeffects
Priority: undecidedlow
Resolution: duplicate
Status: newclosed

Duplicate of #10394.

comment:4 Changed 7 years ago by dwilks

How long before this fix appears in the jquery-git build? I updated my jsfiddle to jQuery (edge) and it's still crashing in exactly the same place. The edge url is: http://jsfiddle.net/ZpgGT/1/

comment:5 Changed 7 years ago by dwilks

This is similar, but not identical to #10394. Please re-open this ticket and test it against jQuery (edge) at http://jsfiddle.net/ZpgGT/1/. Thanks.

comment:6 in reply to:  3 Changed 7 years ago by dwilks

Replying to timmywil:

Duplicate of #10394.

Ahh, maybe replying is what's needed to get your attention. :)

This is similar, but not identical to #10394. It has nothing to do with the effects module. It's a similar issue in data.js. Please re-open this ticket and test it against jQuery (edge) at http://jsfiddle.net/ZpgGT/1/. Thanks.

Note: See TracTickets for help on using tickets.