Bug Tracker

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#12172 closed bug (duplicate)

Event binding on disconnected element causes memory leak in IE7

Reported by: johnhunter Owned by:
Priority: undecided Milestone: None
Component: unfiled Version: 1.8rc1
Keywords: Cc:
Blocked by: Blocking:

Description

Creating a disconnected element and then binding an event handler to it causes all subsequent bind calls to leak their elements. When the page is unloaded references remain for every element that has a binding.

Browser: IE7
Test environment: sIEve-0.0.8 (http://home.wanadoo.nl/jsrosman/)
Test case: http://jsfiddle.net/johnhunter/3nFL7/ (will need to run this outside of jsfiddle to avoid side effects in IE7)

Steps to reproduce:

  1. Save test case to local server.
  2. Load in sIEve.
  3. Reload page (or use auto-refresh)

Expected result:
No leaked elements detected.

Actual result:
The tt element is leaked along with a div (one of jQuery's support test elements)

Can also replicate this with the following:

  • jquery-1.7.2
  • jquery-1.7.1
  • jquery-1.6.1 (with additional leaking support elements)

so this is not new to 1.8.

This issue may also effect IE8 but I am unable to confirm at present.

Change History (3)

comment:1 Changed 10 years ago by johnhunter

Duplicate of #12171 - please close. (bug submission causes py errors)

comment:2 Changed 10 years ago by dmethvin

Resolution: duplicate
Status: newclosed

comment:3 Changed 10 years ago by dmethvin

Duplicate of #12171.

Note: See TracTickets for help on using tickets.