Bug Tracker

Opened 7 years ago

Closed 7 years ago

#12160 closed bug (invalid)

mouseleave inconsistent with docs, across browsers when using form fields

Reported by: alastair@… Owned by: alastair@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

Here is an example page demonstrating the use of a select box inside a div with the mouseleave handler on it.

http://jsfiddle.net/cEhkU/2/

The behaviour exhibited differs across the browsers I tested it on:

  • In Chromium (18.0.1025.168 Ubuntu 11.10) the mouseleave event triggers as soon as I click on the select box
  • In Firefox (14.0.1 Ubuntu 11.10) the mouseleave event triggers when the mouse pointer moves into the options list

Ideal behaviour is that the options list is considered a child of the div and mouseleave is not triggered until the mouse leaves both the dropdown and the div.

Preferred behaviour would be that the event is not triggered until the mouse pointer leaves the boundary of the div.

Expected behaviour is at least that the mouseleave event does not trigger until the mouse pointer moves to the options list.

It has been suggested that focusing of the select box counts as the mouse leaving the div but I would contest that the mouse leaving the div would at least require the mouse to move, and focusing the select can be done without the mouse at all; hence the focus is irrelevant to the position of the mouse.

Change History (3)

comment:1 Changed 7 years ago by dmethvin

Owner: set to alastair@…
Status: newpending

Can you create a native-DOM demonstration that shows jQuery is the source of this problem? jQuery isn't doing anything to change the timing of these events, so if they are inconsistent you'd need to take that up with the individual browser makers.

comment:2 Changed 7 years ago by anonymous

The docs on the matter made me believe that jQuery implemented these events in all browsers but IE.

Your comment suggests otherwise so I will take a closer look at it all when I have a chance, assuming no one takes interest beforehand.

(This may be a while since I am sans PC at home; apologies if nothing happens for a few days.)

comment:3 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.