Bug Tracker

Opened 7 years ago

Closed 7 years ago

#12084 closed bug (invalid)

`invalid` event not fired when delegated

Reported by: celtric@… Owned by: celtric@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

Demo jsFiddle

I don't know if it's a bug or the intended behaviour, but it sure would be very handy to have this functionality so we don't have to track every DOM manipulation for potential form insertions.

Change History (3)

comment:1 Changed 7 years ago by dmethvin

Owner: set to celtric@…
Status: newpending

It doesn't work, at least in Chrome 20, with or without jQuery:

http://jsfiddle.net/wcVua/6/

The invalid event is not bubbling.

Can you point me to the current standard? The w3c site says WebForms2 has been superceded by HTML5, which says nothing about this event.

http://www.w3.org/TR/web-forms-2/

http://www.w3.org/TR/html5/common-input-element-apis.html#common-event-behaviors

comment:2 Changed 7 years ago by anonymous

I haven't been able find information about it either. The closest thing I've found it's the XForms invalid event which does indeed bubble. I wonder why they decided to disable it in HTML5.

I guess this ticket should be closed, as the problem is not about jQuery anymore.

Thank you for your comment!

comment:3 Changed 7 years ago by dmethvin

Resolution: invalid
Status: pendingclosed
Note: See TracTickets for help on using tickets.