Bug Tracker

Opened 13 years ago

Closed 13 years ago

#1208 closed bug (duplicate)

slideToggle on table row corrupt in Firefox

Reported by: ksnyder Owned by:
Priority: major Milestone: 1.1.4
Component: effects Version: 1.1.3
Keywords: Cc:
Blocked by: Blocking:

Description

When using a slideToggle on a table row in Firefox (1.5.0.11), the row toggles off correctly but does not toggle on correctly. When sliding off if you examine the style property value in Firefox before the slide, it is "table-row". When examining the value after the slide it is "none". When sliding "on" the property display value is "block".

If you check IE, "block" appears as the style property value.

At least on my design this causes an issue.

Attachments (1)

test.html (1.1 KB) - added by randomperson83 13 years ago.
test case

Download all attachments as: .zip

Change History (4)

comment:1 Changed 13 years ago by brandon

Component: ajaxfx
need: ReviewTest Case

Could you provide a simple test-case?

Changed 13 years ago by randomperson83

Attachment: test.html added

test case

comment:2 Changed 13 years ago by randomperson

This bug is ridiculously picky about which tables it manifests itself in. The test case I attached contains three tables, the first two of which work as expected. However, the third table does not work as expected. This is evidenced by the hr element moving towards the bottom of the screen each time you call toggle (which is probably a firefox bug when you set a table row to display:block). The difference between the three tables is that the third table is initially not displayed, and is set as such by a global stylesheet, whereas the first table is hidden by embedded style elements, and the second is initially displayed.

comment:3 Changed 13 years ago by john

Milestone: 1.1.31.1.4
Resolution: duplicate
Status: newclosed
Version: 1.1.21.1.3

Thanks for your feedback - this is a duplicate of another bug (#960), but the information that you've provided is really helpful, so I'm going to link back to it from there. Thanks!

Note: See TracTickets for help on using tickets.