Bug Tracker

Opened 7 years ago

Closed 7 years ago

#12079 closed bug (worksforme)

[Click From Right] Event "click" is execute, when push right mouse button

Reported by: alexei03a@… Owned by: alexei03a@…
Priority: blocker Milestone: 1.8
Component: event Version: 1.8b2
Keywords: Cc:
Blocked by: Blocking:

Description

Is bad working.

Change History (4)

comment:1 Changed 7 years ago by dmethvin

Owner: set to alexei03a@…
Status: newpending

Thanks for taking the time to contribute to the jQuery project! Please provide a complete reduced test case on jsFiddle to help us assess your ticket.

Additionally, be sure to test against the jQuery Edge version to ensure the issue still exists. To get you started, use this boilerplate: http://jsfiddle.net/FrKyN/ Open the link and click to "Fork" (in the top menu) to get started.

comment:3 Changed 7 years ago by dmethvin

Component: unfiledevent
Milestone: None1.8
Priority: undecidedblocker
Status: pendingopen

I don't see the problem in Chrome or IE9, but I do in Firefox. This is a regression we need to fix.

comment:4 Changed 7 years ago by dmethvin

Resolution: worksforme
Status: openclosed

Nope, this is *not* a regression, it has worked this way from the beginning of jQuery. Firefox generates a click event on the document for right clicks whereas most other browsers do not. You can check event.which to see what button is pressed.

If you are using .delegate() or .on() for delegated events, we filter out right clicks since they aren't fired in the directly bound case. However, we don't try to hide right clicks on the document.

Note: See TracTickets for help on using tickets.