Bug Tracker

Opened 7 years ago

Closed 7 years ago

#12067 closed bug (invalid)

Unable to bind mouseenter/mouseleave events for SVG elements

Reported by: jamesh@… Owned by: jamesh@…
Priority: undecided Milestone: None
Component: unfiled Version: 1.7.2
Keywords: Cc:
Blocked by: Blocking:

Description

The mouseenter/mouseleave don't appear to be firing correctly when using jQuery in conjuction with SVG (Raphael 2.0). I know out of the box SVG jQuery isn't 100% compatible with SVG, however, as far as I can see it only seems to effect IE9.

The weird thing is if you rapidly move your mouse on/off the svg element (making sure you come right off the HTML pane in doing so) and back onto it the events do fire (but not everytime). Just to make sure it wasn't a general problem with on I hooked up the click event which works fine, everytime.

I found this similar thread, however, there was no clarification on whether a ticket had been opened for it plus it was for an older version.

jsFiddle demonstrating the problem.

Change History (5)

comment:1 Changed 7 years ago by dmethvin

Owner: set to jamesh@…
Status: newpending

Can you verify that your test case is working properly in IE9 with "jQuery (edge)" selected? It seemed to work for me.

comment:2 Changed 7 years ago by dmethvin

Actually, you'll need to delete jquery.min.js under Resources and add http://code.jquery.com/jquery-git.js. Please always use the uncompressed jQuery for test cases, btw.

comment:3 Changed 7 years ago by anonymous

Will do in future (this is my first ticket).

Actually switching the managed resource to jquery-git.js seems to have fixed it. So can we confirm this is a bug in 1.7.2?

comment:4 Changed 7 years ago by dmethvin

Well, "we" are trying to get 1.8 done at the moment. :) I got your original fiddle to fail in 1.7.2, but switching to jquery-git made it work. I'm not sure which change fixed this bug. If you're familiar with git you could do a bisect on the code and see if we have a test case for the fix to prevent a regression.

comment:5 Changed 7 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.